Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.
export MGUID=`xe vm-install template=centos6 new-name-label="centos 6 test install 3"`
xe vm-disk-add disk-size=11GiB vm=$MGUID sr-uuid=$STORAGE_UID device=0
xe vm-param-set uuid="$MGUID" PV-args="ks=http://server.com/ks.cfg ksdevice=eth0"
xe vm-param-set uuid="$MGUID" other-config:install-repository="http://mirror.switch.ch/ftp/mirror/centos/6/os/x86_64/"
xe vm-start uuid=$MGUID

when i do this i get a error that there is no bootloader. if i add a disk to the template and omit the 2nd command everything works fine.

so the question: how can i boot into installation after adding disk(s)

share|improve this question
add comment

1 Answer 1

I'm trying to follow along here:

When I run the vm-disk-add line, i get

"A device with the name given already exists on the selected VM device: 0 "

Meaning that I already have a disk at position 0. This is true; my template includes a disk in slot 0 when it's made.

I guess my question is, why do you want to do it this way. What if you put a disk on the template with a small size, and then expand it to the size you want before doing the vm-start. Would this have the same desired effect?

Does this page help you at all?:

http://forums.citrix.com/thread.jspa?threadID=290306&start=0&tstart=0

Regards,

Port Forward Podcast

share|improve this answer
    
well it would somehow have the same effect. none the less i would like to figure out why this happens and how i can get into "installation from kickstart mode" –  yawniek Oct 24 '11 at 17:52
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.