Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

My Squid HTTP proxy works fine with authentication. Here is the config:

auth_param basic program /usr/lib/squid/pam_auth
auth_param basic children 5
auth_param basic realm test-proxy
auth_param basic credentialsttl 4 hours
auth_param basic casesensitive off

But I want that my locally running applications which use the proxy don't have to authenticate. How to disable authentication for requests from localhost?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

Something like

acl localhost src 127.0.0.1
acl auth proxy_auth REQUIRED
http_access allow localhost auth

should do the trick.

share|improve this answer

Better still - don't proxy for local requests - this is easily set up in browser config, group policy, proxy.pac etc. - there is generally no real case for local proxying.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.