Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using KVM in cents 5.6. I am trying to do offline migration between two machines. I have a common NFS server. I initially save the state of the running VM (on machine1) to a state file using :

/usr/libexec/qemu -m 1024 -hda image1.img (to start the vm) stop migrate "exec:gzip -c > state.gz"

It successfully saves the state. Now I can resume the vm on the same machine with :

/usr/libexec/qemu -m 1024 -hda image1.img -incoming "exec:gzip -c -d state.gz"

It works fine. But is I use the same command in machine 2, I get :

gzip: stdout: Broken pipe.

Either the vm doesn't give any output or it starts from scratch and not from the memory state. I dont know the mistake I am committing. It will be great if someone can give me some pointers, tips or help on this issue. Thanks a lot.

  • Sethu
share|improve this question
have you tried it without gzip? – dyasny Jul 29 '11 at 10:50
Yeah in that case I get cat: write error: broken pipe. – sethu Jul 29 '11 at 14:51
up vote 1 down vote accepted

[Solved] It is a dumb issue which I didn't think of. Even though both machines are running the same OS with same kernel, the qemu version on machine 1 was 0.10.5 and the other machine was 0.12.4 . I downgraded the second machine's qemu version to 0.9.1 and it works now.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.