Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to get Openfire to install on an Ubuntu virtual machine, however upon completing the web based installer, I am unable to login to the admin panel.

So far I:

  • downloaded Debian installer
  • Installed using stock options
  • Added database and built the structure using supplied SQL file
  • Completed web based installer

I am now trying to login using username: admin and my password, however I constantly get a wrong username/password error. There is a record generated in the MySQL database showing the admin user with an encrypted password, and changing to an unencoded password doesn't work. What is the problem here?

share|improve this question

16 Answers 16

up vote 16 down vote accepted

I had the same issue, little know and it seems undocumented bug. Try rebooting the server after the you do the install.

Worked for me.

share|improve this answer
2  
+1 I also had this same exact error on Ubuntu, and couldn't figure out what I was doing wrong. Turns out that I wasn't restarting the service after installing and configuring Openfire. A reboot shouldn't really be needed on a linux machine unless you're doing a kernel upgrade. –  Cory Plastek Jul 13 '09 at 18:54
1  
This "trick" also works on Windows. –  alves Jul 30 '09 at 15:16
    
what alves said. I'd been bugging around for some while now. Trying to set new usernames and passwords. Read this. Did a clean install. Restarted the server after install, and SHAZAM! works like a charm. –  peirix Sep 17 '09 at 13:32
    
Same problem/solution on Fedora. –  saturdayplace Oct 26 '09 at 20:13
    
Don't mean to bump an old thread, but I came across this because I had the same problem. I didn't need to reboot the actual server, just restart the service. This was with version 3.6.4-1, so I'm not sure if this has change throughout the versions. –  pferate Feb 4 '11 at 22:41

I had to manually set the password, the setup page didn't save it. Restarting the server didn't help.

If you are using the embedded db on Windows, this will be in embedded-db/openfire.script:

INSERT INTO OFUSER VALUES('admin',NULL, ...

Change the NULL to your password. Then restart your OpenFire server.

share|improve this answer
    
This worked like a charm for me! –  David Apr 1 '10 at 20:38
    
This worked for me. –  Alconis Jan 30 '12 at 14:00
    
This worked for me too, and since I'm only using Openfire as a XMPP server for a "kata" I don't care about security issues with this technique. –  Håkon K. Olafsen Mar 30 at 18:37

http://blog.taragana.com/index.php/archive/how-to-recover-openfire-admin-password/

however this is not programming related....

share|improve this answer
    
I have been through these steps before, however it didn't seem to help. The issue persists even when installing a mysql DB or embedded –  Lobe Jun 21 '09 at 4:16

We install and deploy OpenFire on Ubuntu fairly regularly. Here is a PARTIAL quick cut/paste from our internal company Wiki. We also pre-install webmin and/or virtualmin on some servers just to make things easier later on:

Pre Install

sudo -s

apt-get update && apt-get dist-upgrade

mkdir /home/kpwadmin/openfire-install

mkdir /home/kpwadmin/virtualmin-install

cd /home/kpwadimn/virtualmin-install

apt-get install sun-java6-jre

Installation

Download the latest .deb package from openfire.org. We will use the 3.6.2 version of Openfire in this article.

cd /home/oacadmin/openfire-install

wget http://www.igniterealtime.org/downloadServlet?filename=openfire/openfire_3.6.2_all.deb

Install the openfire_3.6.2_all.deb using dpkg

dpkg -i openfire_3.6.2_all.deb

Create a MySQL database for Openfire

Launch firefox and go to serverip/phpmyadmin (example: 72.11.123.59/phpmyadmin), login to phpmyadmin as root.

click privileges

add a new user

Username: openfire

Host: local

Password: "something secure"

Under the section titled "Database for user" click the radio button "create database with same name and grant all privileges"

click 'go'

Web Interface

Open another tab on firefox and go to serverip:9090 (example: 123.0.0.59:9090) to continue the install using the web interface.

select english

Etc, etc, etc.

Hope this helps...

share|improve this answer
    
Without phpMyadmin: mysql -u root -p; create database openfire; GRANT ALL PRIVILEGES ON openfire.* TO openfire@localhost IDENTIFIED BY 'password'; FLUSH PRIVILEGES –  pauska Jul 24 '09 at 9:15

Openfire Admin Login How to change Openfire's admin login when using Windows Vista and an embedded database:

  1. Shut down Openfire
  2. As the Windows Administrator, Edit

    C:\Program Files (x86)\Openfire\embedded-db\openfire.script

  3. Change the line that looks something like this

    INSERT INTO OFUSER VALUES('admin',NULL,'', 'Administrator','admin','0','0')

    to

    INSERT INTO OFUSER VALUES('admin','',NULL, 'Administrator','admin','0','0')

  4. Save the file, exit the editor

  5. Restart Openfire
share|improve this answer

I installed openfire.deb package to ubuntu server and had the same problem: couldn't even login for the first time as admin. I did the following: chmod o+rx /usr/share/openfire

Turned out that users didn't have permissions to even read the directory. I don't know if that's right thing to do, but now i can log in :)

share|improve this answer

Had the same issue with an install on Windows using the embedded database option. Uninstall, wipe directory, reinstall did not fix it. Only a reboot would cure it

share|improve this answer

I had the same problem with 3.6.4, so I downloaded 3.6.3 and it works fine.

You can replace the '4' with a '3' in the download link to get 3.6.3...

share|improve this answer

Restarting didn't do it for me, Following the advice above, I manually edited the openfire.script too (I was using embedded database) and then I was able to login just fine (Ubuntu 9.10)

share|improve this answer

I logged in successfully with an LDAP-authentication-based setup with MySQL server. I logged in as "admin" with the supposedly updated password, which is still "admin". I hope this helps someone else who's probably pulling their hair out just like me.

P.S.: http://www.yosemitescouting.org/images/Yosemite%20Sam.bmp

share|improve this answer

I installed and de-installed several times on Windows XP Profesional SP3 machine using the embedded database of Openfire 3.6.4. Could not login to adminconsole. The last install I rebooted directly after install and lets me log in now :)

I hope this helps the frustrating feeling of not getting to login while you just set the password!! Strange bug, though.

share|improve this answer

My install on CentOS 5.3 gave the same results. I am unable to login as admin after the install.

I restarted both the HTTP and Openfire server. Login was granted after that.

[root@server ~]# service httpd restart
Stopping httpd: [  OK  ]
Starting httpd: [  OK  ]

[root@server ~]# service openfire restart
Shutting down openfire:
Starting openfire:
share|improve this answer

See this complete tutorial for installing Openfire with fixing common problems.

http://www.expertcore.org/viewtopic.php?f=74&t=1851

share|improve this answer

Using Openfire 3.7.1 on Windows the password for user admin was admin, too -- no matter what I entered during the setup wizard.

Thanks to this answer I found the line

INSERT INTO OFUSER VALUES('admin','admin',NULL,'Administrator','admin@example.com','0','0')

in the embedded-db/openfire.script file so it was easy to figure out.

share|improve this answer

It defaults to "admin" for user, and "admin" for password even if you supply one with embedded on windows (Just fyi).

share|improve this answer

Make sure you are logging in with just the username and not the whole email address you used to create the account (eg. if you setup admin@example.com, login with just admin).

If you have punctuation or special characters in your login password, that will cause a problem - but in the OP's question, you are using an account with a valid password.

According to the official docs:

  1. Reset or add the admin info in the ofproperty table:

    DELETE FROM OFPROPERTY WHERE NAME='admin.authorizedJIDs';
    INSERT INTO OFPROPERTY VALUES('admin.authorizedJIDs','admin@example-com,new@example.com');
    

    If you are using the embedded database, then you can run these queries by editing embedded-db/openfire.script

  2. Or add another admin to the conf.xml.

    <admin>
        <authorizedJIDs>admin@example.com, new@example.com</authorizedJIDs>
    </admin>
    

    Based on this page though, I suspect that this setting has been renamed to <authorizedUsernames> instead of <authorizedJIDs>

  3. You can also rerun setup, though in my experience, that hasn't always helped.

    edit /conf/openfire.xml and change the <setup> tag to false
    
  4. For completeness, others have answered above that you can edit the ofuser table. [Haven't had much luck with that myself].

Don't forget to stop and restart openfire after making changes, including running setup. [Yes, I know that's silly. Do it anyways if you want OpenFire to work.]

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.