Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We upgraded our Ubuntu with Xen to 10.04 after the upgrade it will boot into the regular ubuntu, however it will not boot into the Xen (3.3) kernel.

Our output :

Screen output

What we tried :

  • increase rootdelay on the vmlinuz line in grub
  • rootwait

Result :

none, it always falls back to a shell that doesn't respond to anything.

Has anyone come across this error ?

share|improve this question
    
serverfault.com/questions/199444/… –  quanta Jul 29 '11 at 6:50
    
he is running ubuntu not Xen, we already looked at that solution too –  Lucas Kauffman Jul 29 '11 at 14:47
add comment

2 Answers

up vote 1 down vote accepted

We ended up booting ubuntu and migrating the images to KVM

share|improve this answer
add comment

it doesnt find the root Filesystem because the UUID of the disc is wrong

You have two options:

1.) edit the root part directly in the bootloader grub. Replace UUID=123123..... with the right rootfs /dev/sdaX. Once the system boots run update-grub

2a.) boot a Rescuesystem like grml or SystemRescueCd. If your System is 64bit boot 64bit kernel! - mount the rootfs probably /dev/sda1 to /mnt - then run the following commands to update grub

bash
chroot /mnt  update-grub

2b.) If 2 fails you can reinstall grub with this: - mount the rootfs probably /dev/sda1 to /mnt, then:

bash
mount --bind /dev/ /mnt/dev 
mount --bind /proc /mnt/proc
mount --bind /sys /mnt/sys
chroot /mnt  grub-install /dev/sda

I hope this helps Tim

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.