Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have quite a basic setup

<Directory "/var/www/example.com/public">
    AuthType Basic
    AuthName "Restricted Access
    AuthUserFile /etc/httpd/conf/users
    Require valid-user
</Directory>

This works fine except one aspect, i am using uplodify swfupload and it can't upload files because it triggers a 401 error.

Is there any way the uploader can bypass this?

share|improve this question

Turn off authentication for the upload folder:

<Directory "/path/to/upload/folder">
    ...
    Satisfy Any
</Directory>

You can also do it for only one file with Files directive.

Another way is the pass session ID to the upload script.

share|improve this answer
    
AuthType Basic sends the userid/password with each request. there is no session ID. You should be able to specify that info in the URL http://user@password:example.com/public/ – Chris Nava Jul 29 '11 at 14:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.