Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have Suse server running on one of my lan machines ,localhost, and it is running Websphere application server. I am also running an http apache on the same machine. I have configured my wireless router to open port 80 for my site on the apache on my localhost, and opened port 90 to access an application i am running on the websheper server. Now when i access my real ip address from the internet, with the default port 80, i can see my site. but when i access port 90, i don't get to my application. I have opened port 90 on the firewall, and doing correct port forwarding on my router.

Can anyone help me in figuring out why this is the case... thanks guys

share|improve this question

migrated from stackoverflow.com Jul 29 '11 at 16:18

This question came from our site for professional and enthusiast programmers.

add comment

4 Answers

Just running through a check list of things

  1. Is websphere running and listening on port 90 ? netstat -a
  2. On the same server can you telnet localhost 90 and see the websphere server ?
  3. In case these dont fix it, can you paste netstat -a and sudo iptables -L here.
share|improve this answer
add comment

after reading the above query,

it seems you forgot to add 90 port in environment Websphere variables of WebSphere. As port 80 is and default environment variable.

Webpshere/Environment/Webspherevariables

share|improve this answer
add comment

What do you see when you hit port 90? A timeout? An error page.

I agree with the first answer to check locally and see if anything is listening on 90. If so, see if you can reach 90 via like the telnet command: telnet hostname 90.

But, finally, how did you configure WebSphere to be listening on port 90? WebSphere's internal Web Container by default listens on ports like 9080 and 9443 for https, so to use a low port like 90, you normally have a web server like Apache in front of WebSphere and the WebSphere plugin installed & configured.

Keep in mind that either with or without a front web server, you will have to add a Host Alias alias to the WebSphere Virtual Host that your application is using in order for it to respond to port 90.

share|improve this answer
add comment

Copied over my answer from your question on SuperUser:

Have you checked your Virtual Hosts settings?

In the ISC navigate to Environment -> Virtual hosts -> "your_virtual_host" -> Host Aliases

("your_virtual_host" would be the virtual host name as defined for the application.)

There you would define the host name + port combination used for this virtual host. If e.g. you only have "localhost" defined as host name, accessing from outside via an IP or different host name would not work. If you do not want to differentiate for various applications, put a "*" for the host name to accept all host names.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.