Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a Debian Squeeze server installment, on which I have installed Gnome (because I wanted to be able to use Remote Desktop from Windows and develop directly on the server).

This is working, however, when I try to open up a Gnome Terminal I get the following error:

There was an error creating the child process for this terminal

I have search the web for an answer, and some places, people say it becuase the user is not in the ttygroup. The user I log in with is mol. Doing an id, I get uid=1002(mol) gid=33(www-data) groups=33(www-data),5(tty),1002(mol). This user is in the tty group.

Other places on the web, people are saying it is because /dev/pts isn't mounted, as suggests that you add the following to your /etc/fstab:

none /dev/pts devpts gid=5,mode=620 0 0

This I have also added to my /etc/fstab. Running mount gives me this output:

devpts on /dev/pts type devpts (rw,nosuid,noexec)

So this device is mounted.

This is were I, and the pages I have reached in my search, run out of ideas. What do I do?

PS. Running xterm from the run applications window gives no error, but also no terminal.

share|improve this question
    
What happens when you log in on a console, set $DISPLAY appropriately and try to run gnome-terminal? –  voretaq7 Jul 29 '11 at 18:06
    
I am not sure I fully understand what you want me to try? I log into the server, get a gnome desktop. Then I ssh to the server, set $DISPLAY to :12 in this case, and the run gnome-terminal? It gives me the same error message on the gnome desktop, but nothing more on the console. –  Mads Ohm Larsen Jul 29 '11 at 20:46
    
Hmm, just tried this again. When running the console as root I do get a terminal up and running on the desktop. This is saying Terminal (as superuser) in the title field, and I am logged in as root in this terminal. So it is a permission problem? But where? –  Mads Ohm Larsen Jul 29 '11 at 21:24
add comment

1 Answer

up vote 0 down vote accepted

After a lot of fiddling around, searching through a lot of other sites online, I finally managed to get the terminals working.

Seems as if MAKEDEV was missing from /dev/, and a simple ln -s /sbin/MAKEDEV /dev/MAKEDEV; /dev/MAKEDEV pts worked wonders for my system.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.