Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am a new administrator to Windows Server 2008 R2. I am trying to set up a VPN connection to my server with not much luck. Thus far I can connect to my server with a VPN PPTP connection but I cannot see any of the public files on my server or see any other resources on the lan. I have a dual port LAN card with one set to a static IP address connected to a cable modem. The other lan port is configured to obtain an IP address automatically and is connected to a wireless router/firewall that is then connected to cable modem. All of my other lan resources(workstations) are also connected to this router/firewall. The firewall is enabled on this wireless router. The cable modem is configured as a bridge -- in other words the firewall is turned off. At least that is what COMCAST explained to me. I installed Network Policy and Access Services Role and included,

  • Network Policy Server
  • Routing and Remote Access Services
  • Remote Access Services
  • Routing -- Health Registration Authority & Host Credential Authorization Protocol

The role successfully installed and I am getting "green" on the role status indicators. The server firewall is enabled but I wrote a netsh script to "firewall set portopening All" for ports 1723 and 47. I am using windows 7 VPN login using PPTP protocol and I am directing the VPN connection to the static IP addr lan port. Like I said I can successfully login into my VPN but I cannot see any of my network resources. I can also remote log in with no problems at all.

share|improve this question
add comment

migrated from stackoverflow.com Aug 1 '11 at 2:36

This question came from our site for professional and enthusiast programmers.

3 Answers

For testing you might consider connecting a client directly to the Internet/cable modem connected NIC on the server, then test the ability to establish a PPTP session with the configuration. If the test configuration works, then the cable modem may possibly be blocking GRE (on port 47).

share|improve this answer
    
Yes, I connected directly to the cable modem and I am able to directly VPN in. I checked with COMCAST and they checked the configureation of my modem and they said that it is configured as a pass through. It does not block any ports. When I connect outside of the modem I am able to connect but just cannot see any network resources or any of the server shared files. Any thoughts? –  user871962 Aug 2 '11 at 1:19
    
So a direct connection to the NIC, eliminating the cable modem, works correctly? –  user48838 Aug 2 '11 at 4:22
    
@user871962: The problem is not with the VPN connection. If you're getting connected then that means the VPN is working. In order to see resources on the LAN the RRAS server needs to be configured for LAN routing. –  joeqwerty Aug 2 '11 at 12:24
    
Not necessarily true if there are GRE issues. –  user48838 Aug 2 '11 at 12:39
    
I checked the RRAS settings. The IPv4 router is checke and is set for "LAN and demand-dial routing". –  user871962 Aug 3 '11 at 15:34
show 4 more comments

The problem doesn't appear to be with the VPN if you're getting connected. The problem appears to be with LAN routing. Have you enabled LAN Routing in the properties of the RRAS server?

share|improve this answer
    
I might have not been so clear on my last answer. I am able to get a vpn connection to the server however, I am not able to see the server shares nor can I access any of the network resources. In other words I cannot ping active resources on the LAN. –  user871962 Aug 6 '11 at 15:30
add comment
up vote 0 down vote accepted

I am going to close out this question even though I have not fixed the problem. I am not seeing any convergence on an answer. I very much appreciate all of the responders time and input. I am going to spend the next day starting from ground zero an re-building the vpn connection. If I am still having problems I may open a new question. I know much more from everyone's suggestions and inputs. Again, thanks for all of your help.

Regards, Steve Mansfield

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.