Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am monitoring a Juniper router using MRTG which is installed on a RHEL server.

There are mismatches in the current in/out traffic which is getting displayed by the 'monitor interfaces int_name' command and the one shown in the router MRTG html page.

The mismatch starts when the in/out values in the router crosses 125Mbps. Can anyone please guide any parameter which I need to tweak to get the correct values ?

Thanks.

share|improve this question

migrated from stackoverflow.com Aug 1 '11 at 8:29

This question came from our site for professional and enthusiast programmers.

5 Answers 5

I guess you need to increase MaxBytes value in MRTG configuration. If it's (by default?) set for 100 Mbit network and you have 1 Gbps network, problems start after traffic is higher than 100 Mbps.

share|improve this answer

Consider setting the ABSMax[router] parameter to the size of your pipe, and leaving the MaxBytes[router] value to the smaller number. A pipe sized ABSMax[router] value, with the low MaxBytes[router] value, will let the graph dynamically scale to values you are collecting from the interface.

Depending on your average load, and what you hope to learn from your graphs, you may find ABSMax[router] to be more useful.

share|improve this answer

You need to switch to monitoring the 64 bit counters.

I don't know how to do that with MRTG as I switched to cacti several years ago. I suggest doing the same. Cacti is much easier to use.

share|improve this answer

The MaxBytes value currently has been set as 125000000 in the cfg file.

Can you please tell to what value it has to be increased to fullfill the Gbps need ?

share|improve this answer
    
I would guess 1000000000 –  Matt Simmons Aug 2 '11 at 3:54

I had same problem, in /etc/mrtg.cfg add this:

Target[myrouter]: 1:public@domain:::::2

and it will go up to 1Gbps

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.