Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

So I added Jasper to my classpath, got Apache ant installed and everything seems fine. I went to hsqldb directory and run "ant runServer" & "ant runManager" and both started up. I went to a sample report and ran "ant -p" and it gave me syntax errors, it did not generate the report correctly. That is problem #1. Problem #2 is soon after I tried that, I went back into hsqldb and did the "ant runServer"/"ant runManager" commands, and it shoots out "-bash: ant: command not found" - I restarted the server, which is Linux, and still have the same problem.

Any help is appreciated!

share|improve this question

1 Answer 1

up vote 0 down vote accepted

issue an whereis ant. If it can't find ant, then it is not installed in a location in your PATH.

If it is not installed in a directory in the PATH then either add this location to your PATH or try to execute ant with full path like /usr/local/bin/ant runServer.

share|improve this answer
    
Wow, thank you! It is working great when I type out the entire path to ant. It even worked when I went into "table" demo and did the ant -p, it generated the report no problem. The question now is, am I am set? Say I have PHP linked to generate reports, all I have to do is make sure the path to run the commands are specified? –  Jasperuser Aug 1 '11 at 14:42
    
I would say yes. If you get an error post a NEW question with detailed problem description. –  mailq Aug 1 '11 at 15:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.