Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

We have SSRS (SQL Server Report Service) running on an Amazon EC2 instance.

It had been named report.foo.com using an A record. Recently we changed it to a CNAME referencing the EC2 public DNS name. (Why: This way, report.foo.com resolves to the EC2 public IP address outside EC2, but to the private IP address inside EC2. As you want, for security groups and data transfer charges.)

All is working well, except certain Microsoft web clients started to behave differently.

Example: Deploying a report from Visual Studio to https://report.foo.com/reportserver.

  • Before: It would simply deploy.
  • After: There is a login prompt asking for a username and password for https://report.foo.com/reportserver. If I supply valid credentials, it does work. But I'm puzzled why it's prompting at all, vs. before?

A similar example is links in Excel spreadsheets -- there's a prompt now that didn't exist before.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Because the machines probably aren't members of your Windows domain so the credentials can't simply be passed across like it could when the machine was a member of your domain.

Or was it working when you had the public name setup as a A record but that changed when you switched it to a CNAME record?

share|improve this answer
    
Yes, it was working differently when report.foo.com was set up as an A record. The login prompts started appearing when we switched to a CNAME record. Some client (like VS and IE) prompt now, but only some clients and in some situations. I don't understand why, or how to change that. –  Greg Hendershott Aug 2 '11 at 11:57
    
Strange, the DNS record type shouldn't matter. All the application gets back is an IP address to connect to. I'd double check the IIS settings to make sure that things didn't get screwed up in there somehow. –  mrdenny Aug 2 '11 at 23:28
    
were you always using a FQDN to deploy? I wonder if it is an issue with automatic login in IE support.microsoft.com/kb/258063 –  Jason Horner Aug 17 '11 at 6:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.