Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am running IIS 6.0 on Windows Server 2003 using FastCGI. I have followed the instructions here:

http://www.php.net/manual/en/install.windows.iis6.php

including this line in my command prompt:

cscript %windir%\system32\inetsrv\fcgiconfig.js -add -section:"PHP" ^ -extension:php -path:"C:\PHP\php-cgi.exe"

However, my server does not recognise .php files. How do I configure my server to send php files to the php-cgi.exe, instead of downloading them?

Question is copied from http://stackoverflow.com/questions/6905811/server-cannot-process-php-files-downloads-them-instead

share|improve this question
    
have you tried restarting the server? –  Jeune Aug 1 '11 at 23:53
    
PHP appears to be working. I can run my hello world program from the command prompt using php.exe and php-cgi.exe. The issue seems to be getting the server to associate php files with the executable. –  lowzhien Aug 1 '11 at 23:56
    
@jeune No. It would take down an unknown number of services on my business, so I'd leave that as a last resort. Any other ideas what is causing the problem? –  lowzhien Aug 1 '11 at 23:57
    
You can always align with your services that you will have a down time of say 10 minutes to restart. Isn't that possible? –  Jeune Aug 2 '11 at 0:01
    
it might be a webserver issue, setting your file handler to php extensions. –  hornetbzz Aug 2 '11 at 0:12

1 Answer 1

If you open your IIS manager and browse to "Web Service Extensions" under your server, do you see "PHP ISAPI" in the right pane?

(from here: http://www.iisadmin.co.uk/?p=4&page=2)

share|improve this answer
    
I only have PHP pointing to php5.dll. What is the ISAPI? I downloaded PHP version 5.3 and I don't have the phpisapi.dll that a ton of guides mention. –  lowzhien Aug 2 '11 at 5:55
    
How did you install PHP? –  Matt Simmons Aug 3 '11 at 23:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.