Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have installed SVN on a CENTOS 5 server running WHM/cPanel.

The SVN URL works fine and asks for a password as expected. However when running the svn checkout command or commit command from my local machine authentication is not requested thus allowing anyone to access the SVN repo.

My svn.conf is as follows:

<Location /repos>
DAV svn
SVNPath /home/<user>/repo

Require valid-user

AuthType Basic
AuthName "DEV REPO"
AuthUserFile /etc/svn-auth-conf
</Location>

I used htpasswd to create a user in the file /etc/svn-auth-conf. I then used avnadmin to create a repo at /home//repo and chmod'd and chown'd it to the

Thanks.

(P.s. i followed this guide: http://sven.webiny.com/subversion-on-cpanel-3-with-centos-55-and-easyapache-32/)

share|improve this question
    
Just to clarify: you created a repo at /home/repo or /home/<user>/repo. And what URL did you use to checkout? –  quanta Aug 2 '11 at 15:41
    
For more clarification: You are trying to checkout the repo using the svn checkout svn://svnrepo.com/here command from the command line on your local machine? Did you setup authentication in the svnserve.conf file? –  tfitzgerald Aug 2 '11 at 17:37
add comment

1 Answer

It's been a while, but have you tried clearing the cached auth data in ./subversion/auth? If this is the case, you may want to disable caching by modifying the values of store-passwords/store-auth-creds.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.