Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We have following situation:

  • SBS 2008 that runs Exchange 2007 (built in)
  • Several mailboxes on that SBS
  • One user that uses a hosted exchange mailbox because the user needs Blackberry-services that we host in our datacenter (exchange-2007)
  • That single user has a different maildomain as the other users on the local SBS

Now, if that single user with the hosted mailbox is in the internal network, he permanently gets the username and password-dialog from remote.local-sbs-domain.local. I think Outlook does that because it looks for autodiscover in the local network first.

So, I need to get autodiscover running for internal users and that single external user (because of Out-Of-Office-Assistant, Calendar and so on). Is it possible to tell the SBS to redirect the autodiscover-request for that external hosted domain?

share|improve this question
    
I believe you can manually set the mail server in outlook. Then the autodiscover will check for the autodiscover service from your hosted server. –  Nixphoe Aug 2 '11 at 15:47
    
Nope. I set it to the right Mailserver (I had to, in order to get emails). But Outlook asks for autodiscover in local networks first. It doesn't check, if the local autodiscover is the right one for the configured profile because it expects it to be the right one because the user-account is also from the local network. –  wullxz Aug 2 '11 at 17:03
    
Have you tried setting up Outlook with Exchange Proxy settings? –  Nixphoe Aug 2 '11 at 23:09
    
Sure. Outlook Anywhere... –  wullxz Aug 3 '11 at 12:45
add comment

1 Answer

up vote 1 down vote accepted

The problem is Outlook is preferring the autodiscover information it is finding in Active Directory via SCP and SRV records.

You can enter a few registry values to change that behavior. This registry file is for Office 2010 but if you change the version number it will also work with older version.

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Outlook\AutoDiscover]
"ExcludeSrvRecord"=dword:00000001
"ExcludeScpLookup"=dword:00000001
"ExcludeSrvLookup"=dword:00000001

This link describes the problem in more detail: http://support.microsoft.com/kb/956955

share|improve this answer
    
I implemented this on the problem computer and never heard of the problem until today. So, I guess that helped. Thanks (better late than never :)) –  wullxz Dec 25 '12 at 21:11
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.