Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We're currently (not for long but long enough that I need a solution) on a VPS service running plesk and no matter how much we tweak, we can't seem to get the MaxClients above 10. We've set both of these values in a swtune.conf

ServerLimit 50 MaxClients 50

Restart but no effect. We're seeing a message in the logs:

WARNING: Attempt to change ServerLimit ignored during restart

Help. Is this an issue of the way apache was compiled?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

first figure out if you are using prefork or worker:

 httpd -V

then edit your httpd.config

nano /etc/httpd/conf/httpd.conf

I am unfamiliar with swtune.conf, but it looks like probably an include that contains the tuning directives for either prefork/worker... if it's not taking effect, make sure your httpd.conf is in fact loading it!

  • try to stop & start the server ~& not~ a graceful or restart [this is a rumor that server limit needs - I don't know for sure!]
  • I sincerely doubt that the plesk apache was compiled with a hard limit of 10, I'm not sure that's even possible.
  • ca we see your whole set of directives [cause it sounds like it is trying to load it but failing for some reason]

-sean

share|improve this answer
    
Sean, thanks for this. The hard stop and start seems to have done the trick in taking the swtune.conf settings. I'll comment back if it turns out that I'm mistaken, but this seems to have done the trick. –  tangollama Aug 4 '11 at 4:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.