Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a special server that is going to be used for graphics processing. It has multiple ATI Radeon GPU cards inside it.

Now when I install Ubuntu server straight from CD it runs relatively cool. There is no graphics, it's just the console.

Now I've compiled a DomU kernel and after I start the machine with that kernel the machine fans start spinning up (where they were nearly silent previously) and the machine is running significantly hotter. In fact it's heating up my little room here like a fan heater!

Is there a setting in the Linux kernel source that could be causing this? Much heat seems to be coming from the graphics cards.

share|improve this question
add comment

2 Answers

There is a lot more going on when you've got a VM running idle, as opposed to a system that isn't running a VM. On the other hand, it shouldn't be doing enough to heat up your "little room" (personal server?) significantly, and that heat certainly shouldn't be coming from the graphics cards.

My guess is that you've screwed up the kernel config in your custom build and it's disabled something that was probably quite important to your thermal management, but without knowing what you did, it's hard to point to a cause (there are hundreds of settings that could potentially contribute to this). Don't build kernels unless you know what you're doing; distro builds are almost always going to end up better than yours.

share|improve this answer
    
I'm forced to build a kernel for this hardware –  Matt Aug 2 '11 at 23:15
    
It was based on the ubuntu server config but with the necessary xen features added. –  Matt Aug 2 '11 at 23:16
add comment

I've discovered that this has something to do with the 2.6.39.4 and (possibly) starting it as a console (ubuntu server has no X11).

Even when grabbing the latest natty kernel: http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.39-rc4-natty/

and not rolling my own. I get this problem.

I'm going to try a different kernel and see what happens.

share|improve this answer
    
Definately to do with console mode. Going back to the older kernel 2.6.38.8 doesn't have this issue. –  Matt Aug 4 '11 at 2:07
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.