Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

In my configuration, alerts are enabled.

yet somehow; every time i reboot my nagios cluster, it re-disables-notifications on a handful of services.

Oh nagios gods

Oh Nagios Gods, what have I done to offend thee?? I disable these via the web interface, but low and behold every time i change config and reload nagios, bloop! back to disabled they come.

Getting angry. Please help; i wise ones of Serverfault. I'm out of ideas. >.<

  • Ubuntu 10.04.2 LTS

    Nagios Core 3.2.0

    Apache/2.2.14 (Ubuntu)

    NagiosQL 3.1.1

share|improve this question

2 Answers 2

up vote 1 down vote accepted

It is probably the permissions on your state file, make sure the nagios user has write privs on it.

To find it, grep state_retention_file /usr/local/nagios/etc/nagios.cfg, or wherever your nagios.cfg is.

share|improve this answer

I believe you might want to look at the following option in your nagios.cfg file.

# USE RETAINED PROGRAM STATE

# This setting determines whether or not Nagios will set

# program status variables based on the values saved in the

# retention file. If you want to use retained program status

# information, set this value to 1. If not, set this value

# to 0.

use_retained_program_state=1

----AND ----

# RETAIN STATE INFORMATION

# This setting determines whether or not Nagios will save state

# information for services and hosts before it shuts down. Upon

# startup Nagios will reload all saved service and host state

# information before starting to monitor. This is useful for

# maintaining long-term data on state statistics, etc, but will

# slow Nagios down a bit when it (re)starts. Since its only

# a one-time penalty, I think its well worth the additional

# startup delay.

retain_state_information=1

share|improve this answer
1  
The problem isn't that is is not retaining state information, the problem is that it isn't retaining new state information. –  opsguy Aug 2 '11 at 23:00
    
opsguy is correct. Those settings are both 1, it is retaining information, just some some point its gotten "stuck". the website can update it but nagios cannot. Permissions must be askew some how. –  GruffTech Aug 11 '11 at 16:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.