Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have installed collectd-5.0.0 on Fedora12 server and would like to run its service for receiving data from clients. I have enabled network plugin and rddtool plugin as commented:

collectd.conf in server:

BaseDir "/opt/collectd/var/lib/collectd"
LoadPlugin "logfile"
LoadPlugin network
LoadPlugin rrdtool
<Plugin network>
 Listen "192.168.8.37" "25826"
</Plugin>

collectd.conf in client:

LoadPlugin logfile
LoadPlugin cpu
LoadPlugin network
LoadPlugin memory
<Plugin network>
 Server"192.168.8.37" "25826"
</Plugin>

collectd.log in server:

[2011-08-03 02:36:04] Exiting normally.
[2011-08-03 02:36:04] rrdtool plugin: Shutting down the queue thread.
[2011-08-03 02:36:04] network plugin: Stopping receive thread.
[2011-08-03 02:36:04] network plugin: Stopping dispatch thread.
[2011-08-03 02:37:11] Initialization complete, entering read-loop.

collectd.log in client:

[2011-08-02 17:31:44] Initialization complete, entering read-loop.

results thst execute netstat on server:
 netstat -ulpn | grep 25826
udp        0      0 192.168.8.37:25826          0.0.0.0:*                               4744/collectd

problem:
but there is noting in "/opt/collectd/var/lib/collectd/" on ser

yes,I move the port number of "25826" as your propose(But I think this is the default port for coolectd).there is no rdd files recived on server.

collectd.log in client collectd

[2011-08-03 10:01:36] plugin_read_thread: Handling memory'. [2011-08-03 10:01:36] plugin_read_thread: Handlingcpu'. [2011-08-03 10:01:36] plugin_dispatch_values: time = 1312380096.431; interval = 10.000; host = uml; plugin = memory; plugin_instance = ; type = memory; type_instance = used; [2011-08-03 10:01:36] plugin_dispatch_values: time = 1312380096.431; interval = 10.000; host = uml; plugin = cpu; plugin_instance = 0; type = cpu; type_instance = user; [2011-08-03 10:01:36] uc_update: uml/memory/memory-used: ds[0] = 280412160.000000 [2011-08-03 10:01:36] plugin: plugin_write: Writing values via network. [2011-08-03 10:01:36] uc_update: uml/cpu-0/cpu-user: ds[0] = 0.100008 [2011-08-03 10:01:36] plugin: plugin_write: Writing values via network. [2011-08-03 10:01:36] plugin_dispatch_values: time = 1312380096.431; interval = 10.000; host = uml; plugin = memory; plugin_instance = ; type = memory; type_instance = buffered; [2011-08-03 10:01:36] plugin_dispatch_values: time = 1312380096.431; interval = 10.000; host = uml; plugin = cpu; plugin_instance = 0; type = cpu; type_instance = nice; [2011-08-03 10:01:36] uc_update: uml/memory/memory-buffered: ds[0] = 344182784.000000 [2011-08-03 10:01:36] plugin: plugin_write: Writing values via network. [2011-08-03 10:01:36] uc_update: uml/cpu-0/cpu-nice: ds[0] = 0.000000 [2011-08-03 10:01:36] plugin: plugin_write: Writing values via network. [2011-08-03 10:01:36] network plugin: flush_buffer: send_buffer_fill = 1340 [2011-08-03 10:01:36] network plugin: network_send_buffer: buffer_len = 1340 ... [2011-08-03 10:01:36] plugin_read_thread: Next read of the cpu plugin at 1312380106.429064774.

collectd.log in server collectd:

[2011-08-03 20:18:08] type = network [2011-08-03 20:18:08] type = rrdtool [2011-08-03 20:18:08] network plugin: sockent_open: node = 192.168.8.37; service = 25826; [2011-08-03 20:18:08] fd = 3; calling bind' [2011-08-03 20:18:08] Done parsing/opt/collectd//share/collectd/types.db' [2011-08-03 20:18:08] interval_g = 10; [2011-08-03 20:18:08] timeout_g = 2; [2011-08-03 20:18:08] hostname_g = localhost.localdomain; [2011-08-03 20:18:08] Initialization complete, entering read-loop.

It looks like, data is sending but doesn't be recived. Where is the mistake?

share|improve this question

migrated from stackoverflow.com Aug 2 '11 at 23:57

This question came from our site for professional and enthusiast programmers.

    
Did you check your iptables setup You probably are missing: Add the line before the first REJECT line: -A INPUT -m state --state NEW -m udp -p udp --dport 25826 -j ACCEPT –  Eazy Mar 27 at 15:00
add comment

2 Answers

try with

LoadPlugin logfile

basically removing the " " from the loadplugi line

also, should help (not sure about it) loading the plugins FIRST THING in the server conf file

LoadPlugin logfile
LoadPlugin network
LoadPlugin rrdtool
BaseDir "/opt/collectd/var/lib/collectd"
<Plugin network>
 Listen "192.168.8.37" "25826"
</Plugin>
share|improve this answer
    
I change it as your propose, but it does not work also, and the phenomenon is the same as before. there is nothing in /opt/collectd/var/lib/collectd/. –  bery Aug 2 '11 at 9:58
    
can you try recompiling collectd with --enable-debug? it's easier for you to check if plugin is working –  Samuele Mattiuzzo Aug 2 '11 at 10:03
    
I recompile collectd with --enable-debug,and I restart collectd again,the debug infomation printed as below: –  bery Aug 2 '11 at 11:30
    
option = BaseDir; value = /opt/collectd/var/lib/collectd; type = logfile. –  bery Aug 2 '11 at 11:31
    
It looks like rrdtool plugin doesn't work, but why it doesn't work? –  bery Aug 2 '11 at 11:33
show 5 more comments

I have exactly the same issue (yes, I see how old this post is :)) which I described here http://stackoverflow.com/questions/17855026/collectd-server-not-writing-down-received-client-data

Unfortunately can not leave it as comment so have to put it this way.

In the end, I rebuilt manually collectd with debug support (taking into consideration that collectd-dbg also looks that have bug and doesn't work as desired) but still no luck.

I'm 1000% sure that everything is fine up to application layer, but can't figure out what's up with Collectd and why it's not handling data which are received via UDP.

Tried to trace it with strace as well, but no luck yet, looks like it's literary ignoring it.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.