Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

According to this article: http://blog.xen.org/index.php/2011/06/02/xen-celebrates-full-dom0-and-domu-support-in-linux-3-0/

Xen is now fully supported in the Linux kernel without patches.

What is missing for xen support in e.g. 2.6.39.3 that you would download from kernel.org that is now available in 3.0?

It's a little confusing. I'm new to Xen and I am putting together a xen server that has GPU passthrough for 2 ATI Radeon cards and I'm just wondering whether I should straight go with Linux Kernel 3.0 if it's all there? I thought it was previously.

I'm looking at starting off with Ubuntu Natty. Any recommendations or links that might help me along the way?

share|improve this question
    
oops nevermind. It seems that it is there in 2.39 but not in others. However you can download pre-patched sources which is what all the blogs and howto articles showed. –  Matt Aug 3 '11 at 1:33

1 Answer 1

With 3.0 the kernel includes support for the xen block backend, which allows you to hand over storage devices (block devices) from dom0 to the domUs.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.