Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have following situation.

  • Computer A is my user computer on which I work. On this computer I would like to use Excel and be able to connect to SSAS thru HTTP.
  • Computer B is machine which holds IIS.
  • Computer C is machine which holds SSAS.

  • Computer A is under LAN A and ActiveDirectory A.

  • Computers B and C are under LAN B and ActiveDirectory B.
  • Computer A has access only to Computer B so that's why I have to use http proxy (msmdpump.dll) to get to Computer C.

SSAS is running as domain service account. I've set Computer B as "trusted for delegation" and ssas-domain service account as "trust this user for delegation to any service" and registered his SPN (http/hostname:81; http/hostname.domain:81).

When I try to connect to http url with Excel I get error. Also with SSMS I get error saying: unsupported data format.

With Excel I try to connect with Data-FromOtherSources-FromAnalysisServices. I type server name as http://server-ip:81/OLAP/msmdpump.dll and specify my domain credentials for LAN B I get: unable to connect to data source, reason, unable to locate database server.

But when I try to enter http://server-ip:81/OLAP/msmdpump.dll in browser I get soap fault which means it's successfully configured?

<soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/"><soap:Body><soap:Fault xmlns="http://schemas.xmlsoap.org/soap/envelope/"><faultcode>XMLAnalysisError.0xc10e0002</faultcode><faultstring>Parser: The syntax for 'GET' is incorrect.</faultstring><detail><Warning WarningCode="1090584599" Description="The 'Invariant Language' locale for UI is not supported." Source="Unknown" HelpFile=""/><Error ErrorCode="3238920194" Description="Parser: The syntax for 'GET' is incorrect." Source="Unknown" HelpFile=""/></detail></soap:Fault></soap:Body></soap:Envelope>

Also I forgot to mention that I have enabled only basic authentication in IIS.

share|improve this question

1 Answer 1

Problem solved. I had anonymous authentication enabled, I've disabled it now.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.