Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

So I setup a simple PPTP VPN on my EC2 Ubuntu instance. However, when I'm connected to that VPN from my laptop, I'm unable to access any AWS-hosted sites/services (times out). Everything else works.

I've tried accessing the same sites from the instance itself, and that works fine.

As far as routing goes, this is what I have:

iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE


Link encap:Ethernet  HWaddr 12:31:3d:00:9c:c3  
inet addr:  Bcast:  Mask:
inet6 addr: fe80::1031:3dff:fe00:9cc3/64 Scope:Link
RX packets:21277177 errors:0 dropped:0 overruns:0 frame:0
TX packets:20872214 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000 
RX bytes:18763465606 (18.7 GB)  TX bytes:3316560823 (3.3 GB)

routing table:

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface   U     0      0        0 eth0         UG    100    0        0 eth0

any pointers?


share|improve this question
iptables isn't routing, it's firewalling. Your routing table, amongst other things, might be instructive. –  womble Aug 3 '11 at 10:23

2 Answers 2

You should use an Elastic IP if you have assigned one, otherwise you can use the private (ex: or public (ex DNS.

share|improve this answer

I know this is old but I had the same problem and it waasn't easy to find the answer.

I found it here, item number 4:

It gives this little extra command that solved it:

iptables -A FORWARD -p tcp --tcp-flags SYN,RST SYN -j TCPMSS --clamp-mss-to-pmtu
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.