Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I just bought my webserver with iweb and to be quite honest, I don't know how to setup a dedicated webserver properly.

I have been able to install httpd, php, mysql but it doesn't seem complete. Also, if I want to install the latest versions of php 5.3.6 using yum commands, how do I do that.

I need help with
->Installing php 5.3.6 along with apc
->Make sure it is compatible with the rest of the configuration

Other php, httpd config to speed up the php. I was gonna ask how to setup nginx as proxy server, but I thought it would be better as a separate question.

share|improve this question
1  
Don't you mean php 5.3.6? –  Sgaduuw Aug 3 '11 at 14:34
    
oh yes, thanks. Will change that. –  Kuldeep Singh Aug 3 '11 at 14:53

1 Answer 1

up vote 1 down vote accepted

Here you go:

yum install php53 php53-mysql php-pear gcc

wget http://pecl.php.net/get/APC-3.1.9.tgz

tar zxf APC-3.1.9.tgz

cd APC-3.1.9;phpize

./configure --enable-apc

make && make install

Add APC Stanza to /etc/php.ini:

; APC Settings
extension= "apc.so"
apc.enabled=1
apc.shm_segments=1
apc.optimization=0
apc.shm_size=64M

service httpd restart

HTH, but if you couldn't find this online you're probably in for a tough time administering this server...

share|improve this answer
    
could you provide me with some of your bookmarks that you use for reference? –  Kuldeep Singh Aug 3 '11 at 16:20
    
also, i am having a problem installing other php plugins since they are want to use php-common and this installs php53-common –  Kuldeep Singh Aug 3 '11 at 16:21
1  
@Kuldeep I don't really have any bookmarks per se. A big part of systems administration is just slogging through (sometimes poor/misleading) online documentation and testing/altering for your particular environment. After many years you get a feel for what you should do even if the docs say something else. I'm afraid there's no magic bullet. –  HTTP500 Aug 3 '11 at 17:11
    
@Kuldeep Post a different question for your php-common issue –  HTTP500 Aug 3 '11 at 17:28
    
nice pointers. thanks. i am having a problem installing other php plugins since they are want to use php-common and your method installs php53-common –  Kuldeep Singh Aug 3 '11 at 17:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.