Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am currently using Centos 6. I want to use the latest version of libvirt (libvirt 0.9.4). The machine already has libvirt 0.8.1 installed . I did yum remove libvirt to remove the existing libvirt and I compiled 0.9.4 from source using :

./configure --prefix=/

make

make install

ldconfig

/etc/init.d/libvirtd start

After the installation is complete, I wanted to use the virsh interface. Once I enter virsh , I get :

virsh /lib/libvirt.so.0: version 'LIBVIRT_PRIVATE 0.8.1' not found (required by virsh)

Can somone let me know how to solve this issue? Correct me if I am doing something wrong. Thanks a lot !

  • Sethu
share|improve this question

1 Answer 1

This is because you are still using the stock virsh from CentOS - and that is not compiled against libvirt.

Your best option is to recompile virsh against that version, preferably the same version as the library.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.