Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am running MAMP on OSX Lion, foolishly i upgraded MAMP to Version 2.0.1 yesterday and now I get the following error in my local development environment.

"NetworkError: 500 Internal Server Error - http://localhost/login.php"

Upon inspection of the apache error logs I found the following entry

[error] [client ::1] client denied by server configuration: /Users/Me/Dropbox/www/.DS_Store

I googled and found many suggestions about modifying the directory and making sure AllowOverride is set to 'All' along with adding the entry 'Allow from all' but those settings are correct.

I checked the permissions of .DS_Store and they were set to

-rw-r--r--@

But i changed it to

-rwxr--r--@

and it still didn't work. I then deleted the .DS_STore file and i still can't get it working, any suggestions would be greatly appreciated.

share|improve this question

migrated from stackoverflow.com Aug 4 '11 at 4:24

This question came from our site for professional and enthusiast programmers.

3 Answers 3

This looks to me like you have some sort of access control configured using Allow. The error message is saying that you are being denied access on address ::1 which is the IPv6 loopback address. Check your configuration files for something like

allow from localhost or allow from 127.0.0.1 (or similar) and add ::1 to the list e.g.

allow from localhost ::1
share|improve this answer

It looks like you have rwx permissions set for the user, but read only for the group and world. Not sure why it would need to do anything other than read .DS_Store from the web, but make sure the owner of that file (or any other file you are getting an error for) is the same as the user that you are running MAMP with, otherwise your new set of permissions will do nothing. Also, you said that you are having other issues after you deleted the .DS_Store file. What errors are you getting now?

share|improve this answer
up vote 0 down vote accepted

thanks for the responses. I found out yesterday that when i installed the new version of MAMP it corrupted everything. I then used Appcleaner and fully removed MAMP. I then re-installed the latest version.

Then i realized that it deleted my databases (Stupid Mistake) and it changed a few of my php.ini settings. I had to turn on display_errors and set the errors to E_ALL. Then i re-added my databases to get back to normal.

It was a mess, thanks again for the suggestions.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.