Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I enabled the mod_rewrite in apache by following this article : http://www.lavluda.com/2007/07/15/how-to-enable-mod_rewrite-in-apache22-debian/ but still when i run the cake php folder it say :

URL rewriting is not properly configured on your server.

   1. Help me configure it
   2. I don't / can't use URL rewriting

What should i do?

I checked

apachectl -t -D DUMP_MODULES

it say rewrite module shared .

share|improve this question
1  
Enable log with RewriteLog and RewriteLogLevel and check it. –  quanta Aug 4 '11 at 10:50
    
@quanta i tried for doing log by following commands RewriteEngine On RewriteLog "/absolute/path/to/your/wwwroot/public_html/rewrite.log" RewriteLogLevel 5 I added in apache2.conf at bottom , but then m not able to restart the apache it is giving me error why ? –  Rahul Mehta Aug 4 '11 at 16:12
add comment

2 Answers

up vote 0 down vote accepted

Seems like a bug with cake php as per this link and this one.

-$

share|improve this answer
add comment

Rahul,

set your apache main log to debug so that you can determine why apache isn't starting after adding the rewrite directives.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.