Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm using CentOS 6. I need to configure my YUM to have access to the PostgreSQL repository, but I'm getting an error.

I've followed this guide: http://www.postgresonline.com/journal/index.php?/archives/45-An-Almost-Idiots-Guide-to-PostgreSQL-YUM.html

When I do:

yum install postgresql

I got this error:

[root@andre yum.repos.d]# yum install postgresql
Loaded plugins: fastestmirror, refresh-packagekit, rpm-warm-cache
Loading mirror speeds from cached hostfile
 * base: ftp.di.fc.ul.pt
 * extras: ftp.di.fc.ul.pt
 * updates: ftp.di.fc.ul.pt
http://yum.pgsqlrpms.org/9.0/redhat/rhel-6-x86_64/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404"
Trying other mirror.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: pgdg90. Please verify its path and try again

Someone have any clue on what I should do to correct this?

Best Regards,

share|improve this question

1 Answer 1

up vote 3 down vote accepted

http://yum.pgsqlrpms.org/ is not used anymore, they have relocated to pgrpms.org, this is causing your errors.

Revert your changes, then check http://yum.pgrpms.org/howtoyum.php, this page will tell you to install the CentOS 6 repository RPM from here.

share|improve this answer
    
Hi, thanks for your help. What changes I need to revert? Uninstall pgdg-centos-9.0-2.noarch? –  André Aug 4 '11 at 13:45
    
@André yes, also check that the /etc/yum.repos.d does not contain any more .repo files for postgres. Then install the new RPM –  Sgaduuw Aug 4 '11 at 13:49
    
Ok, thanks. I've successfully installed PG9. But I van't install pgAdmon3. I have configured the Postgresql-yum maninly to install pgAdmin3, but I van't. Give me [root@andre yum.repos.d]# yum install pgadmin3 Loaded plugins: fastestmirror, refresh-packagekit, rpm-warm-cache Loading mirror speeds from cached hostfile * base: ftp.di.fc.ul.pt * extras: ftp.di.fc.ul.pt * updates: ftp.di.fc.ul.pt Setting up Install Process No package pgadmin3 available. Error: Nothing to do –  André Aug 4 '11 at 14:21
    
@André technically, that is a completely different question ;) there is a pgadmin3 package maintained in the EPEL repository, see fedoraproject.org/wiki/EPEL –  Sgaduuw Aug 4 '11 at 14:33
    
great! That link save my day in the PgAdmin installation. Thank you very much for your help. –  André Aug 4 '11 at 14:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.