Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to secure my phpmemcachedadmin installation. (It doesn't come with any sort of security, not even a login system)

I've added this to the .htaccess file:

AuthName "For admins only"
AuthType Basic
AuthUserFile /var/www/phpmemcachedadmin/.htpasswd
AuthGroupFile /dev/null
require user myuser

But it doesn't work. Am I missing something here? The files are owned by www-data, so it can't be a permissions thing.

share|improve this question
    
Is access allowed or denied? What error does your browser show? –  Shane Madden Aug 4 '11 at 21:16

1 Answer 1

up vote 1 down vote accepted

Do you have AllowOverride all in the vhost config for this directory? AFAIK this is required. I would also change the user to require valid-user

share|improve this answer
    
That's it, I somehow thought that was the default setting, but even then in said "None" in the httpd.conf file. Thanks –  skerit Aug 4 '11 at 21:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.