Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have the following setup:

<Location /repos>
  DAV svn
  SVNParentPath /home/svn/repos
  AuthType Basic
  AuthName "SVN"
  AuthUserFile /home/svn/.htpasswd
  Order deny,allow
  Require valid-user
</Location>

Users can access their svn repositories like this:

http://theserver/repos/therepository

If you try to access the following address in the browser...

http://theserver/repos

You get a 403 Forbidden. I'd like to make it so that users can browse that folder and see the repositories.

I thought adding the following

<Directory /home/svn/repos>
  Options +FollowSymlinks +Indexes
  AllowOverride all
</Directory>

Would do it, but I still get 403 Forbidden...

Any thoughts?

share|improve this question
add comment

1 Answer

up vote 3 down vote accepted

Set SVNListParentPath to On and try again.

share|improve this answer
    
That sounds like exactly what I need. I will try that. Thanks! –  Jakobud Aug 5 '11 at 4:15
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.