Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

i have written the webservices suing SOAP, and its still under development. When have set of code which are already running the webapps folder of tomcat6. When I make changes in particular file I replaced only that file but stopping the tomcat server and restarting the tomcat server, but I am not able to see any changes in the application, itself reflecting the old functionality itself. I deleted the whole project and deployed a new project with the same folder name, then also I am not able to see the new changes some times, I get an error in the browser which says resources not found. But it works fine when I create a new folder with different name and deploy application in the new created folder. I am not understand, what actually happening. Kindly help me out

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Tomcat caches servlet response in %CATALINA_HOME%/work/Catalina/localhost/myapp. If you're really desperate you can delete that directory manually. However, normally setting reloadable=true in the Context will make Tomcat automatically reload the Web app. Also, if you deploy it using the manager app instead of just dropping the WAR, that reloads it automatically.

share|improve this answer
    
I am not able to find %CATALINA_HOME in my ubuntu server, how i do it please explain me since I am novice. –  Jeevan Dongre Aug 8 '11 at 10:41
    
I have a FTPServer running in the tomcat6/webapps/myfolder/FTPServer.class, before it was running in a different location inside webapps folder, the previuos path was /webapps/WEB-INF/classes/com/m/f/FTPServer, though the file path is changed when I try to that FTPServer still its taking the old path itself. How do I solve this problem –  Jeevan Dongre Aug 8 '11 at 10:51
    
CATALINA_HOME is a variable either set in your environment or in your tomcat startup script. I don't understand your second question. –  Ernest Mueller Aug 10 '11 at 20:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.