Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to VNC into a Mac OSX machine. I can ssh in fine. I am also running this VNC connection over an SSH tunnel, however it worked fine yesterday.

I'm trying

$ vncviewer

and it connects and gives the following output.

Connected to RFB server, using protocol version 3.8
Performing standard VNC authentication

I enter the VNC password. However it just hangs there and nothing happens. This happens if I enter a known incorrect password and the correct password.

What could be causing this and how would I go about diagnosing this?

share|improve this question
did you try restarting the vnc service? – Simurr Jun 22 '09 at 16:09

I've had similar things happen when the ARD service went fubar and needed a restart. It's fairly simple over SSH.

If you are using a different VNC server then this still applies. Try killing the process and restarting it.

To restart the ARDAgent -


ssh into the box and run

sudo /System/Library/CoreServices/RemoteManagement/ -restart -agent
share|improve this answer
Apple's VNC server is very finicky when using non-Apple VNC clients. If you leave the session open too long, or you let it time out, you will need to restart ARD. – moshen Jun 22 '09 at 17:08
I tried that put that didn't solve it. – Rory Jun 25 '09 at 13:44
up vote 0 down vote accepted

I think this is my fault. I think I was confused about passwords, and was entering the wrong password. D'oh!

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.