Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

When my web site is calling out a bash script with /usr/bin/php i'm geting this error

Failed loading /projects/common/zend/lib/ZendOptimizer.so: /projects/common/zend/lib/ZendOptimizer.so: cannot open shared object file: No such file or directory

the file /projects/common/zend/lib/ZendOptimizer.so is there where it should be i dont know how to resolve this

share|improve this question
    
Do you get the same error when running php -v? –  quanta Aug 5 '11 at 11:10
    
php -v shows this Failed loading /usr/lib/php/modules/ioncube_loader_lin_5.3.so: /usr/lib/php/modules/ioncube_loader_lin_5.3.so: undefined symbol: gc_remove_zval_from_buffer PHP 5.1.6 (cli) (built: Nov 29 2010 16:47:37) Copyright (c) 1997-2006 The PHP Group Zend Engine v2.1.0, Copyright (c) 1998-2006 Zend Technologies –  B14D3 Aug 5 '11 at 11:17

2 Answers 2

the file /projects/common/zend/lib/ZendOptimizer.so is there

And is it readable by the uid PHP is running as? Is the PHP running chroot?

share|improve this answer
    
php is not chrooted .... and the problem was solved .... one of programers moved the file from orginal location.... god how i hate situations like this ;) –  B14D3 Aug 5 '11 at 12:07
    
@B14D3: if the problem was solved, can you either answer the question yourself or close it? –  ℝaphink Aug 5 '11 at 12:43
up vote 0 down vote accepted

Layer 8 error: one of the programers moved the file from orginal location..

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.