Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We have two DC's running Windows Server 2008 R2. Each server has DNS running and one has DHCP running.

I have configured the scopes etc. and added two DNS servers to the configuration:

DNS Server setup

As you can see I have entered the two IP's .50 and .60.

When I try and test this (using a Macbook) I get given an IP address, the gateway is correct and the domain is showing as it should. For some reason though, I only get given one DNS server:

Macbook Network settings

To be on the safe side I double checked 'nslookup':

danny$ nslookup

server Default server: 192.168.1.50 Address: 192.168.1.50#53

Any help or advice would be appreciated!

share|improve this question
    
does a 'cat /etc/resolv.conf | grep nameserver' list just one or both? if only one have a full look at that file to see if there are any anomalies. –  Chopper3 Aug 5 '11 at 11:37
    
That results in 'nameserver 192.168.1.50', and /etc/resolv.conf just shows the domain and the one name server. –  dannymcc Aug 5 '11 at 11:45
    
That's really odd, I have the same client OS but see both servers - have you bounced both client and server? –  Chopper3 Aug 5 '11 at 11:53
    
Ping works all ways, client > server1, client >server2, server1 > client, server2 > client, server1 > server2 and server2 to server1. –  dannymcc Aug 5 '11 at 11:57
2  
I think I've worked out what I missed - I had added the DNS server manually which is why it then ignored the second one. A hint for future ref; if you Mac shows the IP's in grey then they are set by the DHCP server. If they are shown in black then they are manual entries. –  dannymcc Aug 5 '11 at 13:14

2 Answers 2

I think I've worked out what I missed - I had added the DNS server manually which is why it then ignored the second one. A hint for future ref; if you Mac shows the IP's in grey then they are set by the DHCP server. If they are shown in black then they are manual entries.

share|improve this answer

Try adding them in as a scope option rather than just in the server option. -(sorry this was ment to be a comment not an answer)

share|improve this answer
    
there are server level options and scope level options - its just a matter of granularity, scope level sets for only that dhcp scope. have you also made sure you flushed your lease on your system so its not picking up an old one, also dont forget to reload dhcp on the server to take the new values and make sure nothing else is giving out dhcp –  anthonysomerset Aug 5 '11 at 11:49
    
I have restarted the DHCP server, renewed the lease and checked that this is the only DHCP server with this scope. There is another running for IP phones but that starts at .201 and this scope ends at .199. –  dannymcc Aug 5 '11 at 11:59
    
I realise scope options are just a matter of granulairity but scope level options superseed server level options and it is possible to set type 006 (DNS) at both so if they have been set with two dns servers at the server option level and only one on the scope level that could explain it. it's work a quick double check. –  ashmere Aug 5 '11 at 12:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.