Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

since I have installed W3 Total Cache I constantly get "Network unreachable" errors for ONLY about 3-4 random pages on a domain per day. This is unacceptable and I need to solve it even if it's only 3-4 pages.

The only error I see in /var/log/messages is

 printk: 2 messages suppressed.

And then when I restarted "named" (I rarely do) I get the message

**network unreachable resolving '137.7.24.188.in-addr.arpa/PTR/IN':** 2001:610:240:0:53::193#53: 1 Time(s)

Do you think the problem is related to the installation of W3 Total Cache or could it be because I started named without adding ""OPTIONS="-4"" and therefore allowing IPv6

I heard Google is already using IPv6

I am very grateful for any response, because I no longer have any idea what I could do.

share|improve this question
    
Are the errors on pages that are on domains with IPv6 records? –  womble Aug 6 '11 at 2:02
    
Nope. Some random pages. My new theory is that Apache was causing the problem. Every 2 hour a graceful restart. To solve that in WHM go to Statistics and change Bandwith processing from 2 to 24. Another reason for high traffic sites might be log rotation, I changed the Log rotation threshold to 1GB from 300MB to avoid restarts. Will keep you posted –  mashup Aug 6 '11 at 2:50
    
"Network unreachable" seems like a really weird error to get for an Apache restart. –  womble Aug 6 '11 at 3:00

2 Answers 2

Does your server have working IPv6 connectivity to the internet?

Looks like it's trying to resolve that address via an IPv6 name server, and it's unable to do so.

share|improve this answer
up vote -1 down vote accepted

Disabling the entire IPv6 module is not recommend according to CentOS FAQ

Instead do this:

cat /proc/sys/net/ipv6/conf/all/disable_ipv6

If it says 0 then do this:

Add to /etc/sysctl.conf:

net.ipv6.conf.all.disable_ipv6 = 1
net.ipv6.conf.default.disable_ipv6 = 1
net.ipv6.conf.lo.disable_ipv6 = 1

Then open up /etc/sysconfig/named.conf and add

OPTIONS="-4"
share|improve this answer
1  
This answer really has nothing to do with the question... –  MikeyB Aug 9 '11 at 21:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.