Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to remove couchdb in my Ubuntu Server ( 10.04 ) and I received the following error:

dpkg: error processing couchdb (--purge):
 Package is in a very bad inconsistent state - you should
 reinstall it before attempting a removal.
Errors were encountered while processing:
 couchdb
E: Sub-process /usr/bin/dpkg returned an error code (1)

How do i fix this?

I have tried the following commands:

sudo apt-get remove couchdb
sudo apt-get purge couchdb
sudo aptitude remove couchdb

but to no avail...

share|improve this question
    
Your Accept Rate is very low. Try marking some of your answers as solved. (Click the check under the points a post gets) –  Bart De Vos Aug 6 '11 at 6:30

2 Answers 2

up vote 0 down vote accepted

I'd be more worried about how you managed to get your installation so badly wedged in the first place, myself.

Have you tried following the recommendation that dpkg gave you, and reinstalling the package to get everything into a consistent state before you try your purge again?

share|improve this answer
    
hello, yes I have tried the recommendation dpkg gave me. But when I try to install i receive the error message which says: dpkg: dependency problems prevent configuration of couchdb: couchdb depends on couchdb-bin (= 0.10.0-1ubuntu2); however: Version of couchdb-bin on system is 1.0.1-0ubuntu3~lucid1. dpkg: error processing couchdb (--configure): dependency problems - leaving unconfigured Errors were encountered while processing: couchdb –  DjangoRocks Aug 6 '11 at 6:55
1  
Your repositories list is hosed; if you want packages from Lucid, then run lucid; don't try installing individual packages piecemeal, you'll make a mess of it. Upgrade your entire system and be done with it. –  womble Aug 6 '11 at 7:05
    
ok cool. thanks! –  DjangoRocks Aug 8 '11 at 10:43

Try removing it with

sudo dpkg --remove --force-remove-reinstreq couchdb

or

sudo apt-get --purge remove --force couchdb
share|improve this answer
    
Don't recommend using --force-* options; it only makes things worse. –  womble Aug 6 '11 at 6:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.