Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Hell Everyone,

I built a server with the mentioned motherboard. I installed Windows Server 2008 R2 Enterprise on this server.

IPMI is integrated on the motherboard with its own dedicated NIC. I've got that NIC configured with its own IP address. I can remote into it using IPMI, and I can remotely control the server settings before booting the OS ( BIOS, RAID configuration, etc). When the OS boots, I lose the mouse and keyboard. I cannot use the keyboard or mouse when installing the OS either. So the Keyboard and Mouse only work when no OS is loaded. Once the OS loads I lose it - that is my problem.

I've been doing some research and trying a few things, but I have not been successful in fixing this issue. I may be wrong, but based on the things I've found online, it seems that the problem could be caused by the way the OS handles USB.

The server is headless. There is no keyboard, mouse, or monitor plugged into it. When I boot up the OS and remote into it, I cannot see a mouse or keyboard listed in the Device Manager. Based on what I've read, it seems that the OS should detect a mouse and a keyboard when connecting remotely via IPMI.

The following are the solutions I've tried. Nothing has worked so far:

I've updated the firmware of the IPMI component to the latest firmware - 1.33. I made sure that the mouse mode was set to Absolute (Windows OS). I've loaded the factory defaults several times. I've enabled Port64h/60h Emulation under the USB settings in the BIOS. I've disabled USB legacy support in the BIOS. I made sure the firewall wasn't blocking IPMI (disabled the firewall).

And that's about it.

I've found threads in some forums from people having the same issue as me, but they were not running the same OS. They were either running Linux or FreeBSD. Most of them fixed their problem by selecting the right mouse mode (Linux in their case). There was one other that solved the problem by disabling USB Mass Storage mode. He stated "When I set it to disable USB Mass Storage when no image is loaded, the ukbd came alive, and I'm typing this on the IPMI Console. " source:

I suspect the solution described in the previous paragraph is somehow related to my problem. I've found several threads on the internet with issues describing the same problem, but none of them were with Windows Server 2008 R2. Again, I may be wrong, but it seems like that could be the issue. I just don't know how I go about applying a solution in Windows Server 2008 R2.

In any case, I could use your expertise. Maybe I am missing something, or maybe I'm on the right track.

Your help is much appreciated.

Thank you in advance,

share|improve this question
Have you tried contacting Supermicro for support and/or ensuring that any Windows specific support drivers for the hardware are installed as well? – user48838 Aug 6 '11 at 18:32
I've contacted Supermicro already. They suggested some basic things I had already tried. The only new thing they suggested I try was to enable the Port64h/60h Emulation. I did that, but it didn't fix the problem. They have not got back to me since then. So I posted here in hopes that someone would have some ideas I could try. – LDelgado Aug 11 '11 at 1:08
What occurs when the OS is booted in "safe" mode? – user48838 Aug 11 '11 at 6:49
Actually, I am able to select safe mode (the keyboard works on the "Windows Did not shut down successfully" screen). When the system boots up in safe mode, I Can't use they keyboard or mouse still though. – LDelgado Aug 12 '11 at 0:32
Then it does come down to driver issues with the hardware. – user48838 Aug 12 '11 at 5:25

Based on information thus far, maybe two possible options:

  1. Press Supermicro for the appropriate driver/driver setting
  2. Look into disabling the correct existing driver(s) from your current configuration
share|improve this answer
Well, based on what I've read online, and as stated on the link I provided, it seems that disabling USB Mass storage would be a solution. That is not an acceptable solution in my case because I need access to storage devices via USB. I'm still working with SuperMicro Support. They haven't got back to me yet. I will post back if I find a solution to this. In the mean time, if anyone has any ideas, I would appreciate any feed back. Thanks, – LDelgado Aug 14 '11 at 18:15

We have the same issue on Windows 2008 R2. And we have "Unknown USB Device" in Windows Device Manager. After pressing several tens on "Reset USB" on IPMI Web interface the device is detected correctly and mouse and keyboard start to work.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.