Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Some guy configured a Cat 6500 Core Switch on my net to handle MPLS traffic (and it works). The MPLS line is also directly connected to the internet, so our edges and firewalls are bypassed actually. I also have a 2851 router (IOS 12.4) router on my edge and want it to handle the MPLS traffic, but I'm stuck with the config. To me it looks something is wrong with the tunneling.

This is the working configuration of my 6500 Core Switch: (irrelevant configuration is omitted)

!
interface GigabitEthernet1/7
 ip address 10.24.17.254 255.255.255.252
!

!
interface Tunnel2
 ip address 192.168.250.1 255.255.255.0
 tunnel source 10.24.17.254
 tunnel destination 10.7.32.254
!
interface Tunnel3
 ip address 192.168.249.1 255.255.255.0
 tunnel source 10.24.17.254
 tunnel destination 10.7.34.254
!

!
ip route 172.16.110.0 255.255.255.0 192.168.250.2
ip route 172.16.112.0 255.255.255.0 192.168.249.2

ip route 10.7.32.254 255.255.255.255 10.24.17.253
ip route 10.7.34.254 255.255.255.255 10.24.17.253
!

!
router eigrp 1
 redistribute static
 network 10.24.17.0 0.0.0.255
 network 172.16.110.0 0.0.0.255
 network 0.0.0.0
 no auto-summary
!

The same configuration was applied to the router, but it simply doesn't work. We want to connect our 2851's fastport 0/3 to WAN directly instead.

Our topology: Router 2851 -> PIX 525 Firewall (It's a dinosaur? Yes I know that) -> 6500 Catalyst Core Switch

Note: Our side of the MPLS is 10.24.17.254

share|improve this question
    
Is the 2851 replacing the 6500 for access to the MPLS network? –  user48838 Aug 7 '11 at 19:20
    
@user48838 Yeah –  Parsa Aug 8 '11 at 9:11

1 Answer 1

up vote 0 down vote accepted

There is typically a BGP configuration for the MPLS network access. The configuration example does not include one, is that somehow missing?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.