Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I want to setup a pxe boot server for installing linux 11.04 amd64 server edition on some blade servers. I had installed 10.04 last year and it worked nicely. I am following same procedure for 11.04 but it is looking for an installation disk in CD-ROM at 3rd step (after keyboard and language options). I tried exporting linux iso cd using nfs mount but on the client side it is unable to mount and when i try to mount it by using shell (available while installation) it shows network unreachable or no network connectivity. If it is not connected to network then how can it pick up linux kernel image and initrd.gz file from tftp server.

I am almost totally confused. Even a little clarification will be very helpful.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

You don't provide any information on how you did it and what you did the installation before.

But did you try to PXE the ISO from here: http://archive.ubuntu.com/ubuntu/dists/natty/main/installer-amd64/current/images/netboot/

Or why don't you just use the (extracted) netboot.tar.gz from the same location? As it is documented at https://help.ubuntu.com/11.04/installation-guide/amd64/howto-getting-images.html.

share|improve this answer
    
I agree with you that i have not provided enough information but your links gave direction to me. I was assuming that initrd.gz as well as vmlinuz are same for both netboot and cdboot. I was using the one which is used for cd and so it was seeking for cd inbetween. netboot folder contains all the required contents and it booted as expected in the very first go. Thanks again –  Jatin Kumar Aug 11 '11 at 16:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.