Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I want to create a svn repository on CentOS 5.5 and connect to it with TortoiseSVN.

I tried many ways. The last one was this (logged in as root):

# mkdir /home/me/myrepo/
# svnadmin create /home/me/myrepo/

Then I edited (as many posts suggested /home/me/myrepo/conf/svnserve.conf) and added

 anon-access = read
 auth-access = write
 realm = My First Repository
 password-db = passwd

to [general].

The problem is that when I try to do the checkout on the computer I want to access it from (or any other for that matter) the following things happen:

  1. Ask for username (correct)
  2. Ask for password (again correct)

I insert both correctly (tried with 3 different accounts)

  1. Asking for username again (...)
  2. Asking for password again (not so logical...)
  3. Failing to connect with message (the connection was closed unexpectedly)

enter image description here

share|improve this question
    
be more specific about your distro (debian, centos, gentoo, rhel, suse, ubuntu, fedora, etc...) –  Anarko_Bizounours Aug 8 '11 at 10:37
    
Did you install PuTTY and have a default hostname set on that computers? –  quanta Aug 8 '11 at 10:39
    
I have putty, the machine is a vps with lots of sites so no default. –  zozo Aug 8 '11 at 11:18
    
Does it help? –  quanta Aug 8 '11 at 14:55

1 Answer 1

Look there, this website has good tutorial :

Server-World.info You might have missed something while configuring the server. So look there and check to see if you didn't miss something.

You can change the distro looking in the bottom of left menu. and change to the next step of the tuto using the right menu.

Hope this will help you.

share|improve this answer
    
The tutorial is good +1 but I was looking for ssh. Not http :) –  zozo Aug 8 '11 at 11:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.