Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am a new system administrator and I am having trouble getting a remote vpn connection to work properly. I have spent many many hours trying to resolve with no luck. I am trying to set up a vpn for my business. I followed Microsoft's instructions on how to setup the server and client VPN. I followed the instructions with no issues. I am able to vpn into the server or at least my remote client connection says I am connected. I can remotely ping the printers, router, and clients throught the vpn connection. This tells me I am getting a successful vpn connection to the server LN. However, I cannot see any of the server shares. I am using windows explorer and I click the network tab. I presume that I should be able to see the vpn or server however I do not see anything. Is there something I am doing wrong to view the remote vpn server shares?

My configurationg is a pass through cable modem connected to my server and a wireless router. The router is connected to a switch which is connected to all the clients and printers. The server has a dual nic card with one connection going to the cable modem as described earlier and the other connected to the lan switch.

I installed RRAS utilizing the install wizard. I enabled IPv4 Router with "Local area network(LAN) routing only", IPv4 Remote access server, Windows Authentication, and Static address pool with addresses 192.168.0.200 through 192.168.0.209. The LAN router is set up to provide DHCP addressing for the lan but I wanted to use the static pool just in case. The server lan nic connection is set up for a static ip address, 192.168.0.199, subnet mask 255.255.255.0 with no default gateway address. The DNS server addresses are set up with my ISP DNS's. I have not installed anything else on the server. Like I said I can remotely access the router and printer resources using internet explorer and the devices IP addresses. I can remotely ping all of the resources on the lan -- clients, printers, routers, etc. However, I cannot see any of the servers network shares. Am I missing some server installation component? Am I using Windows Explorer correctly?

share|improve this question
    
Can you ping the server over the VPN? Can you see the shares if you NET VIEW \\<SERVERNAME>? What about if you NET VIEW \\<SERVER_IP>? Can you map to the shares using NET USE X: \\<SERVERNAME>\<SHARE>? What about using NET USE X: \\<SERVER_IP>\<SHARE>? –  Mike Insch Aug 8 '11 at 15:43
    
Hello Mike...Ok I am rocking now! Yes, your recommendations worked and I can see the shares. Between your recommendations and joeqwerty I can now set up a "clickable" link to access my shares. Thanks for your help. –  user871962 Aug 9 '11 at 2:47

1 Answer 1

up vote 1 down vote accepted

You're probably not going to see the shares in Network Neighborhood or My Network Places due to the fact that you're probably connecting from a computer that's in a different workgroup or domain and the fact that the traffic (NetBIOS over TCP) that builds the browse list is probably not going to taverse the VPN connection. You should be able to access the shares manually by using a UNC path (\\server\share).

share|improve this answer
    
Hello joeqwerty, ok I am now able to access my server shares. You provided me a lot of insite on my previous post that enabled me to get this far. Thanks very very much. Is it possible to get lan connection to show up in My Network Places or am I asking for too much? I have a number of novice users who can work with typing in the \\server\share\file... however it would make my job easier for them if I could simply provide a My Network Places solution. Again thanks a lot for all of your help. Steve. –  user871962 Aug 9 '11 at 2:30
    
Ok, even better now. I went into My Network Places and was able to set up a single tab by selecting "add network place" From there I just added the path to my remote server share \\<server>\<server share>. Thanks everyone for there help. –  user871962 Aug 9 '11 at 23:52
    
Glad to help... –  joeqwerty Aug 10 '11 at 0:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.