Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Clean install of Tomcat 5.5. I know it's older, but the webapp I am needing does not support newer versions. I can access it just fine using localhost, but I can't get to it from a remote computer. Sends a 404 error. I am really new to this stuff, so if there is something stupid you would not even suggest, please do it anyway. :)

Thanks for any help in advance.

Brian

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Open the /path/to/tomcat/conf/server.xml file and remove address="127.0.0.1" from <Connector tag:

<Connector port="8080" protocol="HTTP/1.1" 
               connectionTimeout="20000" 
               redirectPort="8443" />

EDIT

  netstat -nao | findstr :80

  TCP    0.0.0.0:80             0.0.0.0:0              LISTENING       3180
  TCP    0.0.0.0:8009           0.0.0.0:0              LISTENING       3180
  TCP    74.208.231.23:80       0.0.0.0:0              LISTENING       4
  TCP    127.0.0.1:8005         0.0.0.0:0              LISTENING       3180
  TCP    [::]:80                [::]:0                 LISTENING       3180
  TCP    [::]:8009              [::]:0                 LISTENING       3180

Pay attention to the last column of netstat output. There is a process (PID 4) listen on port 80. Stop all other processes listen on port 80 (Web Development Agent, Microsoft SQL Reporting, ...) and try again.

share|improve this answer
    
Here is my current connector tag: <Connector port="80" maxHttpHeaderSize="8192" maxThreads="150" minSpareThreads="25" maxSpareThreads="75" enableLookups="false" redirectPort="8443" acceptCount="100" connectionTimeout="20000" disableUploadTimeout="true" /> –  Belgarath the Ancient One Aug 9 '11 at 5:15
    
I added in protocol="HTTP/1.1", but that did not change anything. Thanks for the sugesstion, though. –  Belgarath the Ancient One Aug 9 '11 at 5:23
    
Port 80? Is there anything else listen on that port? Which OS are you running? You access from remote computer inside LAN? Please post the full content of server.xml? –  quanta Aug 9 '11 at 5:32
    
The entire content is too big to post, and I don't see an attachments option. Other than the change to port 80, and adding the protocol option, it's the generic server.xml. It was my understanding that 80 was best to run as standalone. OS is Win2K8 R2. Server is hosted, not on LAN. Looks like tomcat has 80 all to itself: Active Connections Proto Local Address Foreign Address State [tomcat5.exe] TCP 0.0.0.0:110 u15728398:0 LISTENING –  Belgarath the Ancient One Aug 9 '11 at 7:12
    
Corrected post:Active Connections Proto Local Address Foreign Address State TCP 0.0.0.0:25 u15728398:0 LISTENING [MESMTPC.EXE] TCP 0.0.0.0:80 u15728398:0 LISTENING [tomcat5.exe] TCP 0.0.0.0:110 u15728398:0 LISTENING [MEPOPS.EXE] TCP 0.0.0.0:135 u15728398:0 LISTENING –  Belgarath the Ancient One Aug 9 '11 at 7:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.