Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Now,

I have munin setup so that it can be accessed by any virtual domain on my server by adding /munin/ to the end of the virtual domain. Apache alias setup looks like this ->

Alias /munin /home/munin/

Now I have just setup nginx as the reverse proxy and everything seems to be working fine with the domain names apart from me being unable to access the munin directory.

If I remove the alias then the munin directory loads up but the static (image files, js files, etc) content doesn't load up.

I have tried adding alias in nginx but that doesn't seem to help by using

location /munin {
    Alias /home/munin
}

The question is not just bound to this one directory but any other directory for example the /usr/share/phpmyadmin/ directory as I am unable to access that aswell after setting up nginx as proxy.

How can I configure nginx to allow me to able to access munin which resides in /home/munin by using the format domainname.com/munin?

Thanks

share|improve this question

migrated from stackoverflow.com Aug 9 '11 at 10:12

This question came from our site for professional and enthusiast programmers.

add comment

2 Answers 2

location /munin {
   root /home;
}
share|improve this answer
add comment

If you are using a different port for the apache proxy such as 8080 or something then you can access munin directly by using apache by using example.com:8080/munin.

I had the same problem and this was an easy solution

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.