Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I receive the following error when trying to access a new virtual host:

Forbidden

You don't have permission to access / on this server. Apache/2.2.17 (Ubuntu) Server at www.local.ttr Port 80

The apache log file for this virtual host contains the following error:

[Tue Aug 09 13:54:42 2011] [error] [client 127.0.0.1] Symbolic link not allowed or link target not accessible: /var/www/ttr

I have set up a .conf file in sites-available and created a symlink to this in sites-enabled. This file has the following content:

<VirtualHost *:80>
    DocumentRoot "/var/www/ttr/Public/public"
    ServerName www.local.ttr
    ErrorLog "/var/log/apache2/ttr-public-error.log"
    CustomLog "/var/log/apache2/ttr-public-access.log" common
php_flag log_errors on
    php_flag display_errors on
    php_value error_reporting 30719
    php_value error_log /var/www/ttr/Public/application/logs/logs.txt
</VirtualHost>
<Directory "/var/www/ttr/Public/public">
        Options Indexes FollowSymLinks
        AllowOverride all
        Order Deny,Allow
  Allow from all
</Directory>

The path /var/www/ttr is a symlink to a folder within my home directory /home/gordon/ttr which contains all projects including a project called Public.

Could anyone give me any pointers on how to fix this problem? It is driving me berserk!

share|improve this question
add comment

1 Answer

Apache should have execute permission for /home/gordon/ttr [and everythng in there]

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.