Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I just installed redmine on my ubuntu server 10.04. Redmine is installed correctly because when I start it as standalone I can access it via mydomain.com:3000.

Redmine is located in /usr/share/redmine.

Now I want to access redmine from a subdomain, e.g. redmine.mysite.com. So I added a redmine file to the /etc/apache2/sites-enabled and /etc/apache2/sites-avialable folder with following content:

<VirtualHost *:80>
        ServerName redmine.mysite.com
        ServerAdmin webmaster@localhost
        DocumentRoot /usr/share/redmine/public

        LogLevel warn
        ErrorLog /var/log/apache2/redmine_error
        CustomLog /var/log/apache2/redmine_access combined

        <Directory /usr/share/redmine/public>
                Options Indexes FollowSymLinks MultiViews
                AllowOverride None
                Order allow,deny
                allow from all
        </Directory>
</VirtualHost>

Then I execute following commands

sudo a2ensite redmine
sudo service apache2 reload 

But my subdomains still shows the default empty plesk page. Any ideas what might be wrong?

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Plesk needs to know that you have reconfigured the domain... try:

/usr/local/psa/admin/bin/websrvmng --reconfigure-vhost --vhost-name=mysite.com

then you want to restart [i.e. service apache2 stop ; service apache2 start] the apache service

check the docs for the full use of websrvmng

/usr/local/psa/admin/bin/websrvmng --help

-sean

share|improve this answer
    
tbanks, but I still get the default plesk page, apache seems to completelly ignore my config –  ArtWorkAD Aug 10 '11 at 7:52
    
sorry - I should have looked closer, your redmine app is listening on port 3000 & apache 80 .. you have been through this:redmine.org/projects/redmine/wiki/… –  Sean Kimball Aug 10 '11 at 14:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.