Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

mysql not started @ server boot automatically but I can start manually as long as log as user "mysql" by using "/etc/init.d/mysql.server" the error I got on the log is

110809  9:16:21  InnoDB: Operating system error number 13 in a file operation.
InnoDB: The error means mysqld does not have the access rights to
InnoDB: the directory.
InnoDB: File name ./ibdata1
InnoDB: File operation call: 'create'.
InnoDB: Cannot continue operation.

so my question is how I can give permission for "root" and mysql start @ boot.

     Note - ./ibdata1 and it's directory are own by mysql

Thanks in advance for any help. p.

share|improve this question
    
what are the current permissions of the ibdata1 file? –  DTest Aug 9 '11 at 19:27
    
660 is the current permission on the file. the data directory is 750 –  dan Aug 9 '11 at 19:33
    
ls -ld /path/to/<MySQL_datadir>? I'm not familiar with Solaris, so is there anything similar to SELinux or AppArmor in Linux? Did you try to disable it? –  quanta Aug 10 '11 at 5:34

1 Answer 1

Your ibdata1 file should be owned by mysql, and read writeable (600)

Make sure your server is running as user mysql as described by the user option

share|improve this answer
    
Thanks for the response, ibdata1 file own by "mysql" and has permission "660" and the sql by user "mysql" I think my issue is why not root unable to start my sql. –  dan Aug 9 '11 at 19:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.