Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Trying to set up Apache/PHP/MySQL development on my Vista laptop, so I thought XAMPP would be a quick and easy solution.

I have this vhost:

<VirtualHost *:80>
    DocumentRoot C:\Development\xxx-projects\xxxx\web
    ServerName miai.local

in httpd.conf I am including it

Include conf/extra/httpd-vhosts.conf

but I'm always getting this error when I visit miai.local:

Access forbidden!

You don't have permission to access the requested object. It is either read-protected or not readable by the server.

If I set up the virtualhost to read from C:\xampp\htdocs\xxxx\web instead of my C:\Development\xxx-projects\xxxx\web folder, it works fine.

It's like some kind of permission problem ... only on Windows. And I've no idea how ownership works on windows!

Any ideas?

share|improve this question

Ah, the answer was my virtualhost was bad. Needed a directory, uh ... directive..:

<VirtualHost *:80>
    DocumentRoot C:\Development\xxx-projects\xxxx\web
    ServerName miai.local
    <Directory C:\Development\xxx-projects\xxxx\web>
        Order Deny,Allow
        Allow from
share|improve this answer

There is an alternate called WAMP, I recollect it worked better for me when I tried setting things up.
There is also a Portable edition that works as well.

Things that are nearby but do not directly compare with XAMPP/WAMP.

  • If you have good bandwidth, there is also the relatively new Opera Unite!
  • I also liked the FreeSSHd
share|improve this answer

@furnace: Not enough rep yet to comment directly on your own answer, but just to note that you might also find it useful to separate the virtual server's logs from the default location:

ErrorLog C:\Development\xxx-projects\xxxx\web\logs\error.log
CustomLog C:\Development\xxx-projects\xxxx\web\logs\access.log combined

Also, you probably realise this, but you could put the VirtualHost directive directly into httpd.conf rather than including it from a separate file.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.