Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've installed Wubi onto a Windows Vista computer. I've also set the boot timeout to 0:

bcdedit /timeout 0

However, now I can't figure out how to get the menu to come up at all! I read on the internets that I had to hold F8 or space when starting up, but they doesn't seem to do anything. Is there a different key or setting I've overlooked?

The computer itself is a Dell that's a few months old. The keyboard is USB, but I don't think that's the problem as I can get into the BIOS just fine. Maybe I'm doing it wrong? Am I supposed to hold the keys or rapidly tap them (I've tried both)?

If it helps, here's the output from bcdedit:

C:\Windows\system32>bcdedit

Windows Boot Manager
--------------------
identifier              {bootmgr}
device                  partition=C:
description             Windows Boot Manager
locale                  en-US
inherit                 {globalsettings}
default                 {current}
resumeobject            {5460d9d2-d391-11dc-9d9f-aba67a8797c5}
displayorder            {current}
                        {e2484fe7-5e97-11de-84d4-0024e8074422}
toolsdisplayorder       {memdiag}
timeout                 0
resume                  No

Windows Boot Loader
-------------------
identifier              {current}
device                  partition=C:
path                    \Windows\system32\winload.exe
description             Windows Vista
locale                  en-US
inherit                 {bootloadersettings}
recoverysequence        {572bcd55-ffa7-11d9-aae0-0007e994107d}
recoveryenabled         Yes
osdevice                partition=C:
systemroot              \Windows
resumeobject            {5460d9d2-d391-11dc-9d9f-aba67a8797c5}
nx                      OptIn

Real-mode Boot Sector
---------------------
identifier              {e2484fe7-5e97-11de-84d4-0024e8074422}
device                  partition=C:
path                    \ubuntu\winboot\wubildr.mbr
description             Ubuntu
share|improve this question
add comment

3 Answers 3

up vote 1 down vote accepted

Check and make sure that things like "Legacy USB support" is turned on in your system BIOS if it has it. USB keyboards can be slow to be recognized during the boot process making it hard at times to get to the boot menu.

share|improve this answer
    
Thanks for replying. I can't seem to find anything in the BIOS for legacy USB support. I think you may have identified the problem - when I hold down a key I can hear the motherboard continually beep when the vendor logo flashes, but the sound disappears once the screen is gone. –  Kyle Cronin Jun 22 '09 at 21:27
add comment

Ummm... Why not run bcdedit again and change the timeout value?

share|improve this answer
add comment

This is a bug actually in the Windows Boot Manager. 2 is the new 0. Set timeout to 2 or higher instead of 0 or 1 so you can press F8 to make it show the menu. You can use a tool like EasyBCD to set the timeout from an OS like XP.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.