Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Here is part of log from this night:

Aug 10 00:51:28 randevu dovecot: Time just moved backwards by 196 seconds. This might cause a lot of problems, so I'll just kill myself now. http://wiki.dovecot.org/TimeMovedBackwards
Aug 10 00:54:49 randevu postfix/smtpd[5411]: warning: SASL: Connect to private/auth failed: Connection refused
Aug 10 00:54:49 randevu postfix/smtpd[5411]: fatal: no SASL authentication mechanisms
Aug 10 00:54:50 randevu postfix/master[4517]: warning: process /usr/lib/postfix/smtpd pid 5411 exit status 1
Aug 10 00:54:50 randevu postfix/master[4517]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling
Aug 10 00:55:46 randevu postfix/anvil[5355]: statistics: max connection rate 1/60s for (smtp:70.38.100.6) at Aug 10 00:52:10
Aug 10 00:55:46 randevu postfix/anvil[5355]: statistics: max connection count 1 for (smtp:70.38.100.6) at Aug 10 00:52:10
Aug 10 00:55:46 randevu postfix/anvil[5355]: statistics: max cache size 2 at Aug 10 00:52:24
Aug 10 01:09:13 randevu postfix/smtpd[5528]: warning: SASL: Connect to private/auth failed: Connection refused
Aug 10 01:09:13 randevu postfix/smtpd[5528]: fatal: no SASL authentication mechanisms
Aug 10 01:09:14 randevu postfix/master[4517]: warning: process /usr/lib/postfix/smtpd pid 5528 exit status 1
Aug 10 01:09:14 randevu postfix/master[4517]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling
Aug 10 01:10:14 randevu postfix/smtpd[5538]: warning: SASL: Connect to private/auth failed: Connection refused
Aug 10 01:10:14 randevu postfix/smtpd[5538]: fatal: no SASL authentication mechanisms
Aug 10 01:10:15 randevu postfix/master[4517]: warning: process /usr/lib/postfix/smtpd pid 5538 exit status 1
Aug 10 01:10:15 randevu postfix/master[4517]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling
Aug 10 01:11:15 randevu postfix/smtpd[5551]: warning: SASL: Connect to private/auth failed: Connection refused
Aug 10 01:11:15 randevu postfix/smtpd[5551]: fatal: no SASL authentication mechanisms

Don't get it. How to fix this.

After system reboot at morning everything went back to normal. But how to prevent this in future?

I have read http://wiki.dovecot.org/TimeMovedBackwards and i have ntpd running on background.

Any tips would be welcome.

Thanks.

share|improve this question
    
Is this a physical or a virtual server? –  Janne Pikkarainen Aug 10 '11 at 11:26
    
it's virtual server –  Somebody Aug 10 '11 at 11:32
    
Then it is like the wiki says "a virtual server" issue (see under Bugs/Issues). Run the NTPD in the host and not the guest and let the guest synchronize the time with the host. NTPD is not allowed in guests. –  mailq Aug 10 '11 at 11:40

3 Answers 3

up vote 0 down vote accepted

At least VMware can be problematic with certain Linux kernel / distribution versions. Luckily they have recommended options for several Linux flavours in their Knowledge Base. (I'm just lucky guessing you are using VMware).

Also operations performed at virtual host, such as snapshots, can cause all kind of troubles.

share|improve this answer
    
Using VirtualBox from Oracle and Ubuntu package from turnkey –  Somebody Aug 10 '11 at 11:48
    
@Janne thank you for the link. It's now in the Dovecot Wiki{1,2}, too. –  mailq Aug 10 '11 at 12:32
    
@mailq: Oh, cheers! Glad to help :) –  Janne Pikkarainen Aug 10 '11 at 13:16

Time drift within virtualized guests is common. The various "guest additions/utilities" aim to address that. In situations where there are no "guest additions/utilities" for an OS, then running regular time synchronizations/updates may be acceptable depending on the application

share|improve this answer

If you have Virtualbox then the "time problem" maybe present there, too. Normally not, but who knows? But fortunately Sun/Oracle provide information about how to handle this. http://www.virtualbox.org/manual/ch09.html#idp13754496

Keep in mind that this time jumps do come from virtualization and have to be fixed in the Host, the Guest and/or the Guest Additions.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.