Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a server running Microsoft SBS 2003 (no exchange). I have IIS installed, and need to get the server address to open a different address opposed to the standard companyweb.

Right now when you navigate to my server on the domain http://crm -- it comes up with the "Welcome to Windows Small Business Server 2003 To get started, click a link." page. But I need it to load a site from Programfiles > CRM > CRM web instead. And also have it accessible on port :5555.

Any help would be appreciated - thanks!

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Create a new web site bound to "All Unassigned" IP addresses for ports 80 and 5555 and select the "CRM" directory you referenced as the web site's home directory. Configure a "Host Header" on the port 80 binding for "crm" (and create a host header for "crm.fully-qualified-domain.com" if you want it to be accessible with the FQDN, too). Finally, create a CNAME record in your domain's DNS zone for "crm" referring to the name of the Windows SBS Server computer.

That will preserve the default web site configuration (which you may need for other services-- Remote Web Workplace being the main one I can think of) but give you what you're looking for.

Edit:

I've got a couple of minutes while I'm waiting on some files to copy so I thought I'd feed my Server Fault addiction... >smile<

This is Microsoft's Dynamics CRM software, eh? (I got that from reading your other questions... I hadn't looked there until this moment). I don't have any experience with this software. I suspect that there's more configuration in the web site that the product's installer creates than just pointing it at a "home directory" and leaving the rest of the IIS settings as-default. A fairly determine searching effort isn't bringing me to any documents that describe what to do if you've deleted this web site by accident (which would be a similar scenario), so I can't say for sure what needs to be done to create the site.

I suspect that IIS 6 may not be setting the proper default document name and there may be some authentication issues, too (like not allowing anonymous access to the default document to force authentication). That's just my gut talking after reading the few things I did.

If this server isn't production for any other role I'd beat on the setup a little more, concentrating in particular on any logs the setup might generate that could give you some clues as to why it's not creating its web site.

share|improve this answer
    
OK, I have my site in there, I have all others "stopped" (I don't need any others) - its "all unassigned" with port 5555, but I don't know how to have it have two ports as you suggested? I can't do 80,5555 in the properties window... –  bMon Aug 10 '11 at 21:08
    
@bMon: You can add multiple bindings for the site. You need to go to the "Advanced..." dialog (from the "Web Site" tab of the site's Properties sheet) and add the additional bindings under "Multiple identities for this web site". –  Evan Anderson Aug 10 '11 at 21:11
    
I'm having problems adding the CNAME "A alias (cname) cannot be added to this dns name. The dns name contains records that are incompatible with the CNAME." Is this step necessary? I have one site under the IIS shouldn't I be able to access it via crm or the IP of the server? My parent issue with all this is my CRM install is completing and the last step is to point to the CRM server (which is the same server) but it doesn't see it. The install put all the files in the IIS automatically - it just serving up those files for the crm like it should. –  bMon Aug 10 '11 at 21:29
    
@bMon: You're not going to be able to access the "CRM" site via the machine's IP address unless you add a host header for the IP address to the site. re: the CNAME - What exactly are you trying to add for a CNAME? I'm expecting that you're adding a CNAME to the DNS zone for your domain with the "Alias name" set to "crm" (w/o quotes) and the "Fully qualified domain name (FQDN) for target host" set to "SBS-server-name.yourdomain.com". Is that what you're adding? –  Evan Anderson Aug 10 '11 at 21:45
    
I'm going to DNS>CRM>Forward Look up Zones > company.local - then in there are 5 entries: SOA, NS, A, CNAME (which is named companyweb with crm.company.local. as the data) and last is Host(A) with the name crm and the server IP as the data. –  bMon Aug 10 '11 at 21:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.