Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have made several bootable disks: CentOS amd64, CentOS i386 and the HP SmartStart software. My second hand server refuses to boot to any of them, displaying the message: "non system disk or disk error replace and strike any key when ready"

share|improve this question
1  
And the BIOS is capable of doing that? And is configured accordingly? –  mailq Aug 10 '11 at 17:25

3 Answers 3

Make sure the drive is actually functional. I've had plenty of media drives on G3 ProLiants die after 5 years or so. Do you have a USB CD/DVD you can try with?

Other than that, enter the Rom-Based Setup Utility (RBSU) and make sure the "Boot Order" is set to hit the media drive before the Smart Array controller.

share|improve this answer
    
Thanks for the response, I have checked in the RBSU and found the "Boot Controller Order". You're right, the Smart Array controller is listed before the PCI IDE controller, but I don't seem to be able to change this order as the setting appear to be read only. –  Jonny Aug 10 '11 at 17:36
    
Well, that only applies to boot disk settings. If your CD/DVD is listed first in the standard Boot menu, then you have the right setup. Your drive may not work, though. Can you test with a USB unit or a drive from another server? –  ewwhite Aug 10 '11 at 17:37
    
I have another server drive available, though that server was having the same issue as the one I'm currently testing on. I will try the drive just in case, however. –  Jonny Aug 10 '11 at 17:40
    
Just tried out the other drive I had available, it gives the same error, it could be possible that both drives are shot, but I believe that the servers came from an environment where they were used regularly. Any other ideas? –  Jonny Aug 10 '11 at 17:51
    
I'm going to try a PXE boot instead. Wish me luck! –  Jonny Aug 10 '11 at 18:19

I have HP Proliant DL360 G4 series server and it was not recognizing the portable CD/DVD ROM then I used USB external CD ROM. I changed the Booting order from USB Drive and it worked from that.

share|improve this answer

Check the BIOS is configured to boot from the CD before the internal disks.

share|improve this answer
    
@Jonny Can you edit your question to include the information that's led you to that theory? –  Shane Madden Aug 10 '11 at 17:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.